Author Topic: Forum Issues  (Read 461 times)

Offline Alan Simmonds

  • Administrator
  • Masters Class Poster
  • *****
  • Posts: 476
  • Flying Class: FAI Pilot (P)
  • Other Status: Judge
Forum Issues
« on: 16, May 2017, 09:10:26 PM »
A couple of issues have recently developed with the forum and I would really like to discover how many members are affected and in what way.

Firstly, one member has reported seeing this:

Quote
Forbidden
you do not have permission to access /smf.index.php on this server. Additionally a 403 forbidden error was encounter while trying to use a ErrorDocument to handle the request.

Has anyone else experienced this? If so, what you doing - starting a new thread, replying, did it include an image etc.?

Secondly, whilst investigating that, I noticed that our server virtual memory resources are being limited again. This is a well known problem and I am waiting for our web host to fix it. This can affect the forum speed and cause server errors when trying to post. If you experience a server error other than the one above, you may be able to refresh the browser and get the post to complete.

I hope we can get this sorted quickly so please let me know if you are getting any errors.

Thanks & regards
Alan


Offline Phil Lewis

  • GBRCAA Member
  • Intermediate Class Poster
  • *****
  • Posts: 86
  • Flying Class: Clubman Pilot
  • Other Status: None
Re: Forum Issues
« Reply #1 on: 16, May 2017, 09:35:41 PM »
Alan I think that this is caused by cut and pasting from a website where one unwittingly copies the web page code as well as the text, the server then see's that as some kind of command which of course it won't accept.

Offline Yoda

  • Son of Scotland
  • FAI Class Poster
  • *****
  • Posts: 653
  • Champ
    • WC 2011
  • Flying Class: None
  • Other Status: None
Re: Forum Issues
« Reply #2 on: 16, May 2017, 10:10:35 PM »
Hi Alan,


I received the same message when trying to reply to Dan's new thread on wings. Normally I would type it out in MS Word but the forum always re-formats it so I just typed it straight into the text box. So, two issues really.

Offline Mike Wood

  • GBRCAA Member
  • FAI Class Poster
  • *****
  • Posts: 1,166
  • F3A Precision Aerobatics
  • Flying Class: FAI Pilot (P)
  • Other Status: FAI Pilot (P)
Re: Forum Issues
« Reply #3 on: 16, May 2017, 10:55:55 PM »
Hi Alan

I encountered this for the first time about a day ago.

To recreate the error:

Use Chrome or Edge

Create a reply to this or any other thread

In the message just click one of the emoticons e.g. sad face

Click Post

and should see the message:

Forbidden

You don't have permission to access /smf/index.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

In Chrome and Edge, when you click an emoticon, you see the emoticon in the message just as you would expect, but
in Internet Explorer it converts, say the "sad" emoticon to,  a colon followed by close bracket,  which does allow the post of the reply.

I also found this:

https://wiki.simplemachines.org/smf/Mod_security_-_Having_problems_with_mod_security

This applies if the server is running Apache, for IIS it will be in web config.

(There should be a dot between   web and config, but it won't let me post it with the dot!)

Mike
« Last Edit: 16, May 2017, 11:09:45 PM by Mike Wood »

Offline Alan Simmonds

  • Administrator
  • Masters Class Poster
  • *****
  • Posts: 476
  • Flying Class: FAI Pilot (P)
  • Other Status: Judge
Re: Forum Issues
« Reply #4 on: 16, May 2017, 11:20:24 PM »
Hi Mike

I discovered the mod_security issue some time ago. The edit should already be in place on the server (unless they deleted it).
I didn't realise support for emoticons was on the wane though. Your sad face displays OK in Firefox but not in Chrome or Edge and I got the Forbidden error trying to post this message from Edge.


Edit: Firefox permitted me to post this message complete with emoticons but I was unable to subsequently edit (or even preview) in any browser with emoticons present - I had to delete them first.

Many thanks
Alan
« Last Edit: 16, May 2017, 11:31:47 PM by Alan Simmonds »

Offline Phil Lewis

  • GBRCAA Member
  • Intermediate Class Poster
  • *****
  • Posts: 86
  • Flying Class: Clubman Pilot
  • Other Status: None
Re: Forum Issues
« Reply #5 on: 16, May 2017, 11:25:14 PM »

Agree with what Mike said above, in Edge putting in an emoticon gets that message and taking it out allows it to post.


Phil

Offline Alan Simmonds

  • Administrator
  • Masters Class Poster
  • *****
  • Posts: 476
  • Flying Class: FAI Pilot (P)
  • Other Status: Judge
Re: Forum Issues
« Reply #6 on: 18, May 2017, 06:33:48 PM »
Hopefully, the Forbidden error is fixed now and our emoticons should work.  :)

If it happens again, please let me know what you were doing at the time so we can track the error down.

Thanks
Alan

Offline Peter Jenkins

  • GBRCAA Member
  • FAI Class Poster
  • *****
  • Posts: 691
  • Flying Class: FAI Pilot (P)
  • Other Status: FAI Pilot (P)
Re: Forum Issues
« Reply #7 on: 18, May 2017, 10:25:14 PM »
Alan


Thanks for all your hard work on resolving this matter.


Peter

Offline Mike Wood

  • GBRCAA Member
  • FAI Class Poster
  • *****
  • Posts: 1,166
  • F3A Precision Aerobatics
  • Flying Class: FAI Pilot (P)
  • Other Status: FAI Pilot (P)
Re: Forum Issues
« Reply #8 on: 19, May 2017, 09:49:08 AM »
Well done  :) ;) :) 8) 8)

Mike

p.s. Posted from Chrome!!